Презентация, доклад по информатике в 9 классе на тему Таблицы и массивы

Презентация по информатике в 9 классе на тему Таблицы и массивы, предмет презентации: Информатика. Этот материал в формате pptx (PowerPoint) содержит 12 слайдов, для просмотра воспользуйтесь проигрывателем. Презентацию на заданную тему можно скачать внизу страницы, поделившись ссылкой в социальных сетях! Презентации взяты из открытого доступа или загружены их авторами, администрация сайта не отвечает за достоверность информации в них, все права принадлежат авторам презентаций и могут быть удалены по их требованию.

Слайды и текст этой презентации

Слайд 1
Таблицы и массивы
Текст слайда:

Таблицы и массивы


Слайд 2
Основные темы параграфа.Что такое массив;Описание и ввод
Текст слайда:

Основные темы параграфа.

Что такое массив;
Описание и ввод значений в массив в Алгоритмическом языке;
Цикл с параметром в Алгоритмическом языке;
Расчёт среднего значения элементов массива.


Слайд 3
Что такое массив. Среднемесячная температура
Текст слайда:

Что такое массив. Среднемесячная температура



Такая таблица называется линейной. Она представляет собой последовательность упорядоченных чисел.
Представление таблицы в языках программирования называется массивом.


Слайд 4
Для обозначения элементов таблицы используют индексированные имена. Т[1] =-21 Т[6]= 22,2  имя массива индекс
Текст слайда:

Для обозначения элементов таблицы используют индексированные имена. Т[1] =-21 Т[6]= 22,2 имя массива индекс


Слайд 5
Т[i], Т[к], Т[i+к], индекс- параметр.  Все
Текст слайда:

Т[i], Т[к],
Т[i+к], индекс- параметр.
Все элементы массива должны иметь одинаковый тип.
Тип массива может быть либо целый (цел), либо вещественный (вещ).


Слайд 6
Задача:Записать алгоритм ввода значений в массив температур.алг
Текст слайда:

Задача:

Записать алгоритм ввода значений в массив температур.

алг Ввод массива, вариант 1 вещ таб Т[1:12] цел I нач I:=1      пока I<=12, повторять      нц           вывод ("Т[," I , "]=")           ввод (Т[I])           I:=I+1 кц кон
Цикл с предусловием.

алг Ввод массива, вариант 2 вещ таб Т[1:12] цел I нач для I от 1 до 12 шаг 1 повторять нц      вывод ("Т[",I,"]= ")      ввод (Т[I]) кц кон
Цикл с параметром


Слайд 7
Цикл с параметром
Текст слайда:

Цикл с параметром

Её общая форма такая:

для <параметр цикла> от <начальное значение параметра> до <конечное значение параметра> шаг <величина приращения параметра> повторять нц    <тело цикла> кц


Слайд 8
Расчет среднего значения элементов массиваВычислим среднегодовую температуру.
Текст слайда:

Расчет среднего значения элементов массива

Вычислим среднегодовую температуру. Для этого нужно сложить все 12 значений таблицы и разделить сумму на 12. Полученную величину выведем в качестве результата.

Эту задачу легко решить с помощью электронных таблиц. На рис. 3.13 показана такая таблица. В ячейки В2:В13 заносятся значения температур. В ячейку В14 помещается формула: =СРЗНАЧ(В2:В13). Результат вы видите в ячейке В14.


Слайд 9
=СРЗНАЧ(В2:В13)- формула, которая заносится в ячейкуВ14
Текст слайда:

=СРЗНАЧ(В2:В13)- формула, которая заносится в ячейкуВ14


Слайд 10
алг Средняя температура  вещ таб Т[1:12]
Текст слайда:

алг Средняя температура вещ таб Т[1:12] цел I, вещ Tsred нач         {Цикл ввода}      для I от 1 до 12 шаг 1 повторять      нц           вывод "Т[I", I, "]="           ввод Т[I]      кц         {Цикл суммирования}      Tsred:=0      для I от 1 до 12 шаг 1 повторять      нц           Tsred:=Tsred+T[I]      кц         {Вычисление среднего}      Tsred:=Tsred/12      вывод("Среднегодовая температура=", Tsred кон

Tsred=(T[1] + T Г[2] + T [3] + .... + Т[12])/12


Слайд 11
Итоги урока: 1. Что такое массив?2. Самостоятельно
Текст слайда:

Итоги урока:

1. Что такое массив?
2. Самостоятельно придумайте примеры данных, которые можно организовать в виде массива. В каждом примере отметьте: каким именем можно обозначить массив, как пронумеровать его элементы, какой тип будет иметь массив? Опишите массивы по правилам Алгоритмического языка.


Слайд 12
Д.З.П.413. Для тех же исходных данных, что
Текст слайда:

Д.З.

П.41

3. Для тех же исходных данных, что рассматриваются в параграфе, составьте алгоритм, в котором вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних месяцев, осенних месяцев.
4. Вы посетили магазин и купили 10 видов товара. В таблицу Т[1:10] вы записали количество купленного товара каждого вида. В таблицу С[1:10] записали цены единиц каждого вида товара соответственно. Составьте алгоритм вычисления общей стоимости всех покупок.


Что такое shareslide.ru?

Это сайт презентаций, где можно хранить и обмениваться своими презентациями, докладами, проектами, шаблонами в формате PowerPoint с другими пользователями. Мы помогаем школьникам, студентам, учителям, преподавателям хранить и обмениваться учебными материалами.


Для правообладателей

Яндекс.Метрика

Обратная связь

Email: Нажмите что бы посмотреть